SAR change detection with SNAP

From AWF-Wiki
Jump to: navigation, search

In this tutorial we will use Level-1 Ground Range Detected (GRD) Sentinel-1 data downloaded from the Copernicus Open Access Hub. The example are fire events during 2015 in a peat forest located in Eastern Jambi, Sumatra, Indonesia.

Contents

Data transfer

Download example tutorial data from Jambi or data from your personal region of interest: two Sentinel-1 scenes one pre-event acquisition date and one post-event date. Follow and adapt accordingly the instruction on Downloading Sentinel-2 images. Sentinel-1 data can have different characteristics (product type, polarization, sensor mode and ascending/descending orbit). Make sure, that you have the same characteristics for both images. Set the sensing period (e.g. from 01.06.2019 to 30.11.2019). Select Product type GRD and sensor mode IW. Download the images of the 06.06.2019 and 21.11.2019 (both GRD, VV/VH, IW, Descending).

Esa openhub S1.png

Visualization of amplitude bands

  • Open SNAP Desktop.
  • Go to File → Import → SAR sensors → Sentinel-1 and select the downloaded zip files.
  • Unfold the product folders and Mark the Aplitude_VV bands of both products.
  • Right click Open 2 Image Window.
  • Windows → Tile Horizontally. Both Amplitude bands are shown side by side geometrically linked to each other. The geometry ist still in sensor coordinates in Ascending mode.

Snap sidebyside.png

Subsetting

To reduce the data volume subset the Sentinel-1 scenes.

  • Close horizontal tileing.
  • Zoom to your area of interest.
  • Right click into the image and select Spatial Subset from View....

SNAP Select Subset Area.PNG

  • Besides a spatial subset you could also select for single bands with this tool. Go to Bands subset and select Amplitude_VV.
  • Click OK.

SNAP Subset.PNG


Please note: The image can still be in acquisition geometry, whereby the image appears mirrored.

Radiometric and geometric calibration

Apply Orbit File

  • Select the subsetted product from the previous step within the Product Explorer on the left side.
  • Go to Radar → Apply Orbit File
  • Default settings are fine.
  • Select target product directory.

Snap apply orbit.png

  • Click Run.

Radiometric Calibration

  • Select the product from the previous step within the Product Explorer on the left side.
  • Go to Radar → Radiometric Calibration → Calibrate
  • Select target product directory.
  • Go to the Processing Parameters tab and check sigma0. (You could also use gamma0 processing.)

Snap calibrate.png

  • Click Run.

Single Product Speckle Filter

  • Select the product from the previous step within the Product Explorer on the left side.
  • For speckle filtering, there are many different options of filter algorithms and window size.
  • Use the Lee filter and try a window size of 3x3 and 9x9, what are the differences in your result?
  • Go to Radar → Speckle Filtering → Single Product Speckle Filter
  • Select target product directory.
  • Go to the Processing Parameters tab and select Lee in the Filter drop down menue.
  • Adapt the window size in X and Y direction accordingly.

Snap leefilter.png

  • Click Run.

Range-Doppler-Terrain Correction

  • Select the product from the previous step within the Product Explorer on the left side.
  • Go to Radar → Geometric → Terrain Correction → Range-Doppler-Terrain Correction
  • Select target product directory.
  • Go to the Processing Parameters tab and select SRTM 1sec HGT (Auto Download) in the Digital Elevation Model drop down menue.

Snap terrain correction.png

  • Click Run.
  • Now the image should be correctly displayed, in terms of geometry, and be smoothed.

Repeat all steps for the second acquisiton date product!

Change composite

Create Stack

  • Close all products by marking them all Product Explorer on the left side, right click and Close All Products.
  • Go to File → Open and select both radiometric and geometric corrected images from the previous step with the extension _Orb_Cal_Spk_TC.dim.
  • Go to Radar → Coregistration → Stack Tools → Create Stack
  • Click on Add Opened button on the right side to select the images.
  • Leave the default settings at the 2-CreateStack tab.
  • Go to the 3-Write tab and select target product directory.

Snap stack.png

  • Click Run.

Convert Datatype

  • Select the product from the previous step within the Product Explorer on the left side.
  • Go to Raster → Geometric → Data Conversion → Convert datatype
  • Save as GeoTIFF.
  • Select target product directory.

Snap datatype2.png

  • Default settings are fine.
  • Click Run.

Display in QGIS

  • Open QGIS.
  • Data Source Manger --> Browser --> XYZ Tiles --> Google Satellite
  • Load the change compoisite file with extension _Cnv.tif Data Source Manger --> Raster.
  • Layer properties --> Symbology. Adjust the band assignment: Red = Band 2, Green = Band 1, Blue = Band 1.
  • Adjust opacity of the change layer on top of Google Satellite. Layer Properties --> Transparency --> Global Transparency.

In the bi-temporal change composite red indicates change areas.

Snap change composite2.png

Personal tools
Namespaces

Variants
Actions
Navigation
Development
Toolbox
Print/export